MetaQuerier Beta

MetaQuerier es un plugin para Ruby on Rails que una vez instalado infiere la estructura de la base de datos y de los modelos de la aplicación Rails. Permite hacer consultas, guardar consultas parametrizadas para utilizarlas más adelante y ver la estructura de base de datos.

No requiere ningún tipo de configuración ( a excepción de que tengas instalado ActsAsAuthenticated y quieras deshabilitarlo). Para instalarlo hay que ejecutar:
script/plugin install svn://rubyforge.org/var/svn/meta-rails/plugins/meta_querier
Los prerequisitos son tener una versión de Ruby on Rails mayor o igual a la 1.2.0 (y tener activada la constante RAILS_GEM_VERSION que encontrarás en /config/environment.rb) o en caso contrario, tener instalado el plugin engines.

Una vez instalado podemos crear las consultas (queries), accediendo al controlador /meta_querier (ej: http://localhost:3000/meta_querier)


Guardarlas parametrizadas (Save):


Ver un listado de las queries que existen (List):


Ejecutar las queries (Run):


Como puedes ver este plugin puede ser muy interesante para generar pantallas de administración o incluso pantallas de listados con un esfuerzo mínimo. Forma parte del proyecto MetaRails que pretende hacer Ruby on Rails todavía más Don't Repeat Yourself.

Queda trabajo por hacer, pero antes de continuar me gustaría estabilizar el código actual. Si te interesa puedes ayudarme instalándote el plugin, probando si te funciona y enviándome tus comentarios.

Más información:

Etiquetas: , , ,

Posted by Spejman at 12:04 p. m. | 0 comments | links to this post read on
Recommend Me


XING
View Sergio Espeja's profile on LinkedIn













Enlaces